mirror of
https://github.com/vale981/yabar
synced 2025-03-04 09:01:38 -05:00

The indicator is based on XCB-XKB and `libxkbcommon`. It can be tested using the following configuration: ``` bar-list = ["bar"]; bar: { position: "top"; block-list: ["ya_xkb"]; ya_xkb: { exec: "YABAR_KEYBOARD_LAYOUT"; interval: 1; }; } ``` The followinng new dependencies have been introduced: - libxkbcommon-dev - libxkbcommon-x11-dev - libxcb-xkb-dev Both work with libxcb and allow the usage of XKB through an XCB session. In this case the session `ya.c` created by `src/ya_exec.c` can be used for this indicator, so no extra X11 logic is needed.
10 lines
272 B
Nix
10 lines
272 B
Nix
with import <nixpkgs>{}; stdenv.mkDerivation {
|
|
name = "yabar-dev";
|
|
src = ./.;
|
|
|
|
buildInputs = [
|
|
cairo gdk_pixbuf libconfig pango pkgconfig xorg.xcbutilwm docbook_xsl
|
|
alsaLib wirelesstools asciidoc libxslt makeWrapper libxml2 playerctl
|
|
libxkbcommon
|
|
];
|
|
}
|