poetry2nix/tests/default.nix
Tobias Pflug 148fd890c6 Add wheel file selection according to pep425
Provides a `select` function that picks the most appropriate `.whl` file
based on platform, arch, python version and manylinux/OSX - version.

Unit tests for pep425 are provided as well.
2019-12-10 17:52:08 +01:00

17 lines
952 B
Nix

{ pkgs ? import (fetchTarball https://nixos.org/channels/nixpkgs-unstable/nixexprs.tar.xz) {} }:
let
poetry = pkgs.callPackage ../pkgs/poetry { python = pkgs.python3; inherit poetry2nix; };
poetry2nix = import ./.. { inherit pkgs; inherit poetry; };
pep425 = pkgs.callPackage ../pep425.nix {};
pep425Python37 = pkgs.callPackage ../pep425.nix { python = pkgs.python37; };
pep425OSX = pkgs.callPackage ../pep425.nix { isLinux = false;};
in
{
trivial = pkgs.callPackage ./override-support { inherit poetry2nix; };
override = pkgs.callPackage ./override-support { inherit poetry2nix; };
top-packages-1 = pkgs.callPackage ./common-pkgs-1 { inherit poetry2nix; };
top-packages-2 = pkgs.callPackage ./common-pkgs-2 { inherit poetry2nix; };
bdist-filtering = pkgs.callPackage ./bdist-filtering { inherit poetry2nix; };
pep425 = pkgs.callPackage ./pep425 { inherit pep425; inherit pep425OSX; inherit pep425Python37; };
}