mirror of
https://github.com/vale981/poetry2nix
synced 2025-03-05 09:11:39 -05:00

Drp `poetrylock` and `pyproject` mandatory arguments without default values and drops `src` from `mkPoetryPyhon`. Fix test invocations with invalid arguments.
8 lines
177 B
Nix
8 lines
177 B
Nix
{ lib, poetry2nix, python3 }:
|
|
|
|
poetry2nix.mkPoetryApplication {
|
|
python = python3;
|
|
pyproject = ./pyproject.toml;
|
|
poetrylock = ./poetry.lock;
|
|
src = lib.cleanSource ./.;
|
|
}
|