mirror of
https://github.com/vale981/poetry2nix
synced 2025-03-06 01:31:39 -05:00
10 lines
340 B
Nix
10 lines
340 B
Nix
{ lib, poetry2nix, python37, runCommand }:
|
|
let
|
|
py = poetry2nix.mkPoetryPackages {
|
|
python = python37;
|
|
projectDir = ./.;
|
|
preferWheels = true;
|
|
};
|
|
isWheelAttr = py.python.pkgs.tensorflow.src.isWheel or false;
|
|
in
|
|
assert isWheelAttr; (py.python.withPackages (_: py.poetryPackages)).override (args: { ignoreCollisions = true; })
|