mirror of
https://github.com/vale981/poetry2nix
synced 2025-03-05 09:11:39 -05:00
28 lines
669 B
Nix
28 lines
669 B
Nix
{ pkgs, lib, ... }:
|
|
{
|
|
# Used to find the project root
|
|
projectRootFile = "flake.lock";
|
|
|
|
settings.formatter = {
|
|
build-systems = {
|
|
command = "sh";
|
|
options = [
|
|
"-eucx"
|
|
''
|
|
for i in "$@"; do
|
|
${lib.getExe pkgs.jq} --from-file overrides/sort-build-systems.jq --raw-output --sort-keys < "$i" | ${lib.getBin pkgs.moreutils}/bin/sponge "$i"
|
|
done
|
|
''
|
|
"--"
|
|
];
|
|
includes = [ "overrides/build-systems.json" ];
|
|
excludes = [ ];
|
|
};
|
|
|
|
black.excludes = [ "vendor/**.py" ];
|
|
};
|
|
|
|
programs.deadnix.enable = true;
|
|
programs.statix.enable = true;
|
|
programs.black.enable = true;
|
|
}
|