mirror of
https://github.com/vale981/poetry2nix
synced 2025-03-04 16:51:40 -05:00
15 lines
288 B
Nix
15 lines
288 B
Nix
{ lib, poetry2nix, python310 }:
|
|
|
|
poetry2nix.mkPoetryApplication {
|
|
python = python310;
|
|
pyproject = ./pyproject.toml;
|
|
poetrylock = ./poetry.lock;
|
|
src = lib.cleanSource ./.;
|
|
checkGroups = [ "test" ];
|
|
|
|
checkPhase = ''
|
|
runHook preCheck
|
|
pytest
|
|
runHook postCheck
|
|
'';
|
|
}
|