mirror of
https://github.com/vale981/poetry2nix
synced 2025-03-04 16:51:40 -05:00

- update pinned nixpkgs used for tests - fix the rest of the setuptools fallout - add and test some scientific packages
28 lines
637 B
Nix
28 lines
637 B
Nix
{ lib, poetry2nix, python3, runCommand }:
|
|
|
|
let
|
|
env = poetry2nix.mkPoetryEnv {
|
|
python = python3;
|
|
projectDir = ./.;
|
|
editablePackageSources = {
|
|
dep1 = null;
|
|
};
|
|
|
|
overrides = poetry2nix.overrides.withDefaults (self: super: {
|
|
dep1 = super.dep1.overridePythonAttrs (old: {
|
|
buildInputs = (old.buildInputs or [ ]) ++ [ self.setuptools ];
|
|
});
|
|
});
|
|
};
|
|
|
|
in
|
|
lib.debug.runTests {
|
|
testDepFound = {
|
|
expected = "0\n";
|
|
expr = builtins.readFile (runCommand "path-deps-develop-import" { } ''
|
|
echo using ${env}
|
|
${env}/bin/python -c 'import dep1'
|
|
echo $? > $out
|
|
'');
|
|
};
|
|
}
|