mirror of
https://github.com/vale981/poetry2nix
synced 2025-03-04 16:51:40 -05:00

Some private repositories (such as Devpi) expose the legacy Pypi API (https://warehouse.pypa.io/api-reference/legacy.html). This commit adds a dedicated fetcher which basically queries this API to get the URL pointing to the actual file. Since Pypi still exposes this API, it has been possible to write a test that uses this legacy API. Fixes https://github.com/nix-community/poetry2nix/issues/277.
6 lines
106 B
Nix
6 lines
106 B
Nix
{ lib, poetry2nix, python3 }:
|
|
|
|
poetry2nix.mkPoetryApplication {
|
|
python = python3;
|
|
projectDir = ./.;
|
|
}
|