mirror of
https://github.com/vale981/poetry2nix
synced 2025-03-04 16:51:40 -05:00
11 lines
286 B
Nix
11 lines
286 B
Nix
{ pkgs, lib, poetry2nix, python3 }:
|
|
|
|
poetry2nix.mkPoetryApplication {
|
|
python = python3;
|
|
pyproject = ./pyproject.toml;
|
|
poetrylock = ./poetry.lock;
|
|
src = lib.cleanSource ./.;
|
|
|
|
overrides = poetry2nix.overrides.withDefaults (import ./poetry-git-overlay.nix { inherit pkgs; });
|
|
|
|
}
|