poetry2nix/tests/file-src-deps-level2/default.nix
2022-01-18 21:06:29 +12:00

14 lines
387 B
Nix

{ lib, poetry2nix, python3 }:
poetry2nix.mkPoetryApplication {
python = python3;
pyproject = ./pyproject.toml;
poetrylock = ./poetry.lock;
src = lib.cleanSource ./.;
pwd = ./.;
overrides = poetry2nix.overrides.withDefaults (self: super: {
trivial = super.trivial.overridePythonAttrs (old: {
buildInputs = old.buildInputs or [ ] ++ [ self.poetry ];
});
});
}