mirror of
https://github.com/vale981/poetry2nix
synced 2025-03-05 09:11:39 -05:00
18 lines
440 B
Nix
18 lines
440 B
Nix
{ lib, poetry2nix, python3 }:
|
|
let
|
|
p2nix = poetry2nix.overrideScope' (self: super: {
|
|
|
|
defaultPoetryOverrides = (super.defaultPoetryOverrides.extend (pyself: pysuper: {
|
|
my-custom-pkg = super.my-custom-pkg.overridePythonAttrs (oldAttrs: { });
|
|
}));
|
|
|
|
});
|
|
|
|
in
|
|
p2nix.mkPoetryApplication {
|
|
python = python3;
|
|
projectDir = ./.;
|
|
overrides = p2nix.overrides.withDefaults (self: super: {
|
|
customjox = super.customjox;
|
|
});
|
|
}
|