poetry2nix/tests/composable-defaults/default.nix
2020-07-22 01:21:24 +02:00

18 lines
440 B
Nix

{ lib, poetry2nix, python3 }:
let
p2nix = poetry2nix.overrideScope' (self: super: {
defaultPoetryOverrides = (super.defaultPoetryOverrides.extend (pyself: pysuper: {
my-custom-pkg = super.my-custom-pkg.overridePythonAttrs (oldAttrs: { });
}));
});
in
p2nix.mkPoetryApplication {
python = python3;
projectDir = ./.;
overrides = p2nix.overrides.withDefaults (self: super: {
customjox = super.customjox;
});
}