mirror of
https://github.com/vale981/phoebe
synced 2025-03-04 09:21:40 -05:00

This is a breaking change that will require you to change your Phoebe settings for PostgreSQL. * New database configuration options * Accounts no longer automatically create databases * Databases have `owners' that tie them back to an account * Databases have `users' that grant accounts full access * Databases have `readers' that grant read-only access to accounts * Accounts can use `ident' authentication for local connections if you enable the `allowIdent' option. * Existing accounts that are not configured via Phoebe will be locked so they cannot be used. That way if you delete a user from Phoebe the account will continue to exist, but won't have access to anything.
21 lines
331 B
Nix
21 lines
331 B
Nix
{ pkgs ? import <nixpkgs> { }
|
|
, ...
|
|
}:
|
|
|
|
pkgs.stdenvNoCC.mkDerivation rec {
|
|
name = "phoebe-${version}";
|
|
version = "0.2";
|
|
src = ./.;
|
|
|
|
phases =
|
|
[ "unpackPhase"
|
|
"installPhase"
|
|
"fixupPhase"
|
|
];
|
|
|
|
installPhase = ''
|
|
mkdir -p $out
|
|
cp -rp bin modules lib pkgs scripts $out/
|
|
chmod 0555 $out/bin/*
|
|
'';
|
|
}
|